Welcome to MattzoBricks Forums MattzoTrainController for Powered Up (MTC4PU) Controller does not connect to WiFi

Viewing 2 reply threads
  • Author
    • #4410
      Ulrich SchneiderUlrich Schneider


      All my controllers using ESP8266 boards work like a charm. They connect to the Wifi and MQTT and are integrated into rocrail.

      My ESP32 MTCPU controller, however, does not work properly. I am a bit stunned, because it uses the same network configuration files as the other controllers. I can hook up a Powered UP Hub via Bluetooth, but there is no connection to the Wifi & MQTT.
      I am using the AZ delivery development boards (“WROOM”) and chose the Board “ESP32 Dev Module” on the Arduino application.

      Currently, I tried my luck with firmware 5.0 as the other ones are labeled a bit buggy.

      I am happy for any help or suggestions.

    • #4488
      Joseph BettenhausenJoseph Bettenhausen


      I had the same scenario as you for the past couple of days. I had no problem with the ESP8266 and connecting reed sensors. However, with the same board https://www.amazon.de/gp/product/B071P98VTG/ref=ppx_yo_dt_b_asin_title_o02_s00?ie=UTF8&psc=1
      and selection in the Arduino IDE, I could not get the MTCPU to stay connected to WiFi, the hub was no problem. It connected at first boot to WiFi and then connected to the hub, but then always lost connection to WiFi.
      I also saw this error.
      [WiFiClient.cpp:258] connect(): socket error on fd 55, errno: 113, “Software caused connection abort

      Matthias had mentioned about WiFi frequencies here:

      MTC4PU – MattzoTrainController for Powered Up

      So I also tried naming my 2.4 and 5 SSID different, but that didn’t help either.

      Have you tried the MTC4BT? I tried that last night with a status LED as well and got it working to controll my train with a lot less headache. It also now shows on my router, which the other MTCPU didn’t, because of the short connection. Every day I am more and more impressed with VS Code and glad the project is going in this direction.

      • #4541
        Ulrich SchneiderUlrich Schneider


        thanks for pointing that out. I had some initial issues with the BT as well, but now the MTCBT works. So, I am staying with that one.


    • #5296
      Oscar WagnerOscar WAGNER

      Salut à tous
      J’avais le même problème et je l’ai résolu en in insérant une ligne de code à la fin:
      ” mcLog(“*** DEBUG-INFO ***”);
      mcLog(“WiFi + MQTT connection Status: ” + String(getConnectionStatus() == MCConnectionStatus::CONNECTED));
      while (WiFi.status() != WL_CONNECTED) {

      qui permet de reconnecter le WI-FI et alors tout fonctionne.
      Bonne continuation

Viewing 2 reply threads
  • You must be logged in to reply to this topic.