Viewing 1 reply thread
  • Author
    • #6071
      David GambleDavid Gamble

      I have spent many days trying to get MQTT messages using Mosquitto v2.0 and greater. Finally some success. Mosquitto has upgraded security and Windows Firewall blocks access to Port 1883. See, follow the instructions and create new rules for inbound and outbound messages.
      Good luck, it works for me!

    • #6074
      Matthias RunteMatthias Runte

      You mean as documented on the Mattzobricks website?

      General Section

      (section “MQTT”).

      • #6110
        David GambleDavid Gamble

        Yes I could not connect to the MQTT server until I configured the MS firewall to pass Port 1883. (Windows 10 and Mosquitto 2).

        The proceedure is:

        Windows Defender Firewall window > Advanced Settings > Inbound Rules > New Rule… > Port… > TCP > Specific local ports: 1883 > Allow the connection > Set the Domain, Private and Public as selected > And set a Name: Mosquitto.

        Then, go to Outbound Rules and do the same. See the link above that explains the procedure very clearly

        • This reply was modified 6 months, 2 weeks ago by David GambleDavid Gamble.
Viewing 1 reply thread
  • You must be logged in to reply to this topic.