Welcome to MattzoBricks Forums Sensors Sensor Controller not connecting to Wifi

Viewing 2 reply threads
  • Author
    • #4849
      Max T.Max T.

      Hi guys I need your help (again).
      After I managed to get switches running (with the 0.4 firmware) and now also trains with the new MCT4BT I’m struggeling with the third and final controller I need for my project.

      When I compile and upload my ESP8266 with the sensor software (using 0.4.1) the connected LED keeps flashing and no new device does connect to my router. If I open up the Arduino Monitor and trigger the connected reed sensor it shows a correct trigger true/false message all the time so the software it self seems to work.
      If I keep the same ESP8266 connected to the PC and upload the 0.4.1 switch software it connects directly to Wifi and the switch works fine.
      Both are using the exact same “MattzoController_Libary.h” and the same “MattzoController_Network_Configuration.h” which makes it even stranger and there are definitely no other copies of these files on my PC either.

      I also tried it with a 2nd ESP8266 but same result.

      Do you have any idea what could cause these issues?

      By the way of course I also tried that new 0.5.1 LayoutController, where I first had problems while compiling which I solved the dirty way deleting the parts in the .ino which I didn’t need (bridges, crossings,…) Compiling worked afterwards but the LED also kept flashing and it didn’t seem to connect to Wifi ether.

    • #5002
      Max T.Max T.


      is anybody able to help me on this problem?
      I kept trying it out several times, with no luck. While the 0.4.1 switch controller connects without any problem to wifi and the mqtt server. The 0.4.1 sensor controller and the 0.5.1 layout controller do not connect using the same libaries.

      I’d be happy for any assistance. Thanks.

    • #5338
      jacob verhoeksjacob verhoeks

      I had the same problems. i rewrote part of the wifi connect code to make it more stable.
      i’ll clean it up and share it.

      I seems there is no public github where i can create a pr.

Viewing 2 reply threads
  • You must be logged in to reply to this topic.